JS File are not parsed

JS File are not parsed

Created by: Elia


Date Happened: May 7, 2020


Component: CxSAST


Platform: Windows


Root Cause
  1. No Error Message - Upon checking the Scan Engine logs you can see that JS files are not being parsed. Results in the report might appear to be too few.


Findings:
  1. Node JS version 11 above may not be parsed correctly. This can only be seen by checking if results are accurate enough.


Resolution:
  1. Update to V9.X to support higher versions of NodeJS
  2. Check if NodeJS version being used is supported.


    • Related Articles

    • Error Parsing TSX - Stuck Scan in Scan Queue

      Created by: Elia Date Happened: February 21, 2020 Component: CxSAST Platform: Windows Root Cause: Error Parsing TSX - Stuck Scan in Scan Queue Findings: TSX files are not supported natively by CxSAST v8.9. Resolution: Update to version 9.x or use ...
    • Project's LOC is out of threshold on engine config

      Out of LOC error. Resolution: Config the engine max and min LOC settings-->application-->engine management Note: If in AWS environment, needs to config on lambda environment variables same with autoscaling group
    • ActiveMQ Error

      Created by: N/A Date Happened: August 5, 2020 Component: CxSAST Platform: Windows Root Cause: ActiveMQ Error Findings: Check the activeMQ logs. You will see that the ActiveMQ hostname is not being resolved. Resolution: Update the CxDB components ...
    • NodeJS and CS Project

      Created by: Elia Date Happened: February 21, 2020 Component: CxSAST Platform: Windows Root Cause:  INFO - DeleteFile: file not found: C:\Program Files\Checkmarx\Checkmarx Engine Server\Engine ...
    • SSL being used is self-signed and not trusted

      SSL issue error when triggering a scan. Resolution: Add Checmkarx server certificate to Java truststore.